Tag: hose

By on March 24, 2014

radiator hose. Shutterstock user 7th Son Studio

We had two updates to a previous Piston Slap this weekend, surprisingly within two hours of each other.  Let’s hear from the OP first:

TTAC Commentator sundvl76 writes:

Sajeev, reporting back:

You may be interested in this, if for no other reason than to add to your diagnostic toolbox; my experience certainly can’t be unique: Several comments below your post also suggested the motor mount(s) as the problem. I more recently discussed this with a professional wrench acquaintance, who also said that the mounts can be expected to go south after ~80K miles; he suggested using a padded floor jack to lift slightly on the engine during a time when I detected the “rough” idle (the oil pan on this vehicle, and maybe all Duratec engines, is waffled cast aluminum). Bingo! The vibration ceased when I did that. (Read More…)

Recent Comments

  • DenverMike: Thanks for the advice, but I’ll tell you off too. Those aren’t even shackle bolts. You...
  • Peter Gazis: Actually the Eastern half of the Roman Empire became the Byzantine Empire and stood until 1400 A.D.
  • 28-Cars-Later: Didn’t see it but nice to know rewarding total incompetence is common to both sides of the...
  • conundrum: Ah, the latest trend. Expect to see fresh flat Coca Cola on sale next. Why bother carbonating the muck if...
  • conundrum: More than just axle rust. Heavy corroded rust on spring shackle U-bolts and nuts that would need a full...

New Car Research

Get a Free Dealer Quote

Who We Are

  • Adam Tonge
  • Bozi Tatarevic
  • Corey Lewis
  • Mark Baruth
  • Ronnie Schreiber