By on September 3, 2014

 

TTAC Commentator Eiriksmal writes:

I read your plea for questions, so I’ll lob you a softball. Why has my 2005 Maxima’s TPS decided to randomly poop out on me after doing a warm start?

Specs: 2005 Nissan Maxima 6MT. 135,000 miles. Electronic throttle. Stock air intake + (new, put in the first time the TPS acted up 3K miles ago) K&N filter. The car’s now on its third owner, having spent its whole life in Evansville, IN, Lexington, KY, and now Louisville, KY. At the rust belt’s frayed fringe, I guess. No surface rust anywhere on the car, though. Electrically speaking, it’s in good shape. (Save the rear ABS sensors… a rant for another day)

(Read More…)

Recent Comments

  • tankinbeans: Maybe don’t wax poetic about the “styling.” We have eyes and can see it. That front...
  • Scoutdude: Well no one likes showing someone 200 houses, so I’m thinking in their case they didn’t really...
  • Jerome10: Let the money printing commence! Honestly, these look fantastic. Never a GM guy but they know how to do...
  • Lorenzo: Since I live in San Diego, I wax the car, clean the inside of the windows to prevent fogging, and replace...
  • Lorenzo: Heh. The solution is simple: asians, like Americans, don’t read signs. They just follow the arrows and...

New Car Research

Get a Free Dealer Quote

Staff

  • Contributors

  • Timothy Cain, Canada
  • Matthew Guy, Canada
  • Ronnie Schreiber, United States
  • Bozi Tatarevic, United States
  • Chris Tonn, United States
  • Corey Lewis, United States
  • Mark Baruth, United States