Tag: gmt 360

By on November 24, 2017

 

2009 Chevrolet TrailBlazer

Roland writes:

Hey Sajeev,

A few years ago I was looking for a midsized SUV for my business (kitchen renovations) and ended up with a ’07 4Runner Sport — which my son (and business partner) decided was for him. Not wanting to derail a business and personal relationship, I stuck with my ’01 Silverado pickup.

Recently I’ve been looking at midsized SUVs again (this time for myself), but don’t want anything new, being a firm believer in used vehicles. One option is the Saab 9-7X (here comes the derision!). I like the size, styling, don’t need seven seats, and if I can interpret various articles — it was the best GM SUV of its time, but Saab fans hated it for that reason. I can pick up an ’06 model for about a $1,000 (CDN, with 104K miles) with a blown 5.3-liter engine, no rust, etc. Question: Would this be an opportunity to drop a 6.0-liter into a 9-7X without the harsh ride of a TrailBlazer SS?

Or just find a 5.3-liter replacement engine and keep things as is?

Or am I nuts?

(Read More…)

By on September 22, 2017

2004 GMC Envoy Radiator Cap Leak, Image: OP

Dave writes:

Hello Sajeev,

I have a 2004 GMC Envoy, 4.2-liter six-cylinder, with about 123k miles that seems to be leaking coolant from somewhere around the radiator cap. Every time I come to a stop with the windows down or pull into the garage I can smell antifreeze. The radiator appears full and the reservoir seems to be maintaining a fairly consistent level of the pink stuff. It never leaks enough that I see wet spots except now and then around the cap, and even then it’s only a few drops at most. I’ve taken it to the mechanic; they double checked all the hoses and connections and even replaced the cap, but it didn’t help.

I replaced the cap a second time thinking I got a bad one, but the smell remains. By happenstance the cap I bought happened to be the exact same brand the mechanic used. I’ve attached a picture of the engine bay showing the areas where I can see dried coolant. The perplexing part to me is that, judging by the splatter pattern near the oil fill and the air filter box, some of the coolant seems to be making it to the fan. Still, I never see any wet spots leading in that direction. Do you have any suggestions?

As a side question, I have been getting an intermittent CEL with an associated P0526 code (fan speed sensor). It will come on for a trip or two and then go away on its own. Any chance the supposed coolant hitting the fan could be causing the CEL?

(Read More…)

Recent Comments

  • threeer: Freed…save for the new 2 “gran coupe,” yes…yes, I have. The CLA to me is an absolute...
  • 2manycars: I am all against it, Your Dishonor! I am 100% unwilling to trade privacy for safety and would not buy a...
  • R Henry: 100% of drivers screened to find the 0.000000001% of criminal drunk drivers. Pass. We earned our license....
  • Mark "Bark M." Baruth: I get that the Ford jokes are amusing, but I’ve been harsher on Ford products (see my...
  • jmo: “Because that’s the only reason I can fathom why someone would buy a 228i x-Drive over a loaded-up turbo...

New Car Research

Get a Free Dealer Quote

Staff

  • Contributors

  • Timothy Cain, Canada
  • Matthew Guy, Canada
  • Ronnie Schreiber, United States
  • Bozi Tatarevic, United States
  • Chris Tonn, United States
  • Corey Lewis, United States
  • Mark Baruth, United States
  • Moderators

  • Adam Tonge, United States
  • Corey Lewis, United States