Tag: ZZ4

By on September 9, 2013

CapturePaul writes:

Hello Sajeev,

This is my second time writing in about my Oldsmobile. I solved the cooling problem with a mechanical fan, however now I am having another problem. As you may recall I swapped in a ZZ4 GM Performance 350 CI motor, and now it will “diesel” for awhile after I shut it off. It only does this after it has had a chance to warm up. Do you have any ideas for fixing this?

Thanks,
Paul (Read More…)

By on January 28, 2013

Paul writes:

Long time listener, first time caller. I have a 1982 Oldsmobile 98 Regency Brougham, that last summer I ripped the 307 out of. It now has a Chevy ZZ4 crate motor, backed by a TH 350 transmission. (Gasp! My hero!!! – SM) (Read More…)

Recent Comments

  • Land Ark: This is the first time I’ve realized that self-driving cars don’t need headlights. They just...
  • BunkerMan: It still looks like a sneaker from the side. I’d take the Mazda 3 over this.
  • Speed3: GM needs to give it up and acknowledge that it doesn’t not have the resources or talent to right this...
  • Noble713: Black metal and death metal. A 120GB iPod classic is my primary source of car music. It’s full with...
  • IHateCars: We’re on our second as my wife’s car, she initially had an ’07 FX35 which she loved...

New Car Research

Get a Free Dealer Quote

Staff

  • Contributors

  • Matthew Guy, Canada
  • Ronnie Schreiber, United States
  • Bozi Tatarevic, United States
  • Chris Tonn, United States
  • Corey Lewis, United States
  • Mark Baruth, United States
  • Moderators

  • Adam Tonge, United States
  • Corey Lewis, United States