Tag: rim

By on January 19, 2015

Yum. (photo courtesy: www.crownvic.net)

 

Long-time TTAC Commentator 86er writes:

Hi Sajeev,

Could Piston Slap furnish me with a be-all/end-all explanation about wheel offsets? The more I try to read up on it on the web, the more confused I get. I’m pretty clear that RWD (at least traditionally) went with the low-offset while the FWD revolution made high positive offsets the industry standard, at least in passenger cars.

A few years back, I had purchased a set of winter tires on rims for my trusty ol’ 92 Vic and later after research found out that the rims were medium-offset that went on a 4×4 Ranger of similar years. I’ve heard that putting on a different-offset wheel can hurt steering/suspension parts like ball joints, but I’ve never seen it in black-and-white, so to speak. (Read More…)

By on November 5, 2014
0821141123

Curb Appeal? (photo courtesy: Greg)

Greg writes:

Hello Sajeev, David Holzman says I should write to you about my Mazda concerns.

1. Concern #1. In two out of three dealers there was significant rust at the center of the wheels due to the wheel caps not having been put on. I only took three pictures, but essentially: at New Country Mazda in Saratoga Springs NY 100% of the Mazdas had no wheelcaps on in the lot and were all showing various degrees of rust. That includes the one in the showroom, you can see it in the pic with the tile floor. (Read More…)

By on November 12, 2013

Sajeev writes:

In our last installment of this particular ‘slap, a reader had a question about aftermarket wheels.  The solution was rather simple, the wheels discussed were not hub-centric.  But I also mentioned a horrible “death wobble” problem with my aftermarket reproduction SVT Cobra wheels on my Fox Cougar, solution TBD.  It was a big problem until… (Read More…)

By on March 28, 2013

Lance writes:

Hey Sajeev,

A long time (since roughtly 2006ish) TTAC reader, I thought you might be able to help me out a bit, or point me in the right direction. My car (2007 Honda Civic Si Sedan, 17300 miles when bought used off lease, now currently around 39000 miles) vibrates terribly at highway speed. Starts around 55mph, continues to increase until about 80-85 where it begins to smooth out again. (Read More…)

Recent Comments

New Car Research

Get a Free Dealer Quote

Staff

  • Contributing Writers

  • Jack Baruth, United States
  • Brendan McAleer, Canada
  • Marcelo De Vasconcellos, Brazil
  • Vojta Dobes, Czech Republic
  • Matthias Gasnier, Australia
  • W. Christian 'Mental' Ward, United States
  • Cameron Aubernon, United States
  • J Emerson, United States