Tag: no start

By on August 18, 2015

 

2010_jeep_commander-pic-6910025025120850825

(photo courtesy: productioncars.com)

Brett writes:

Sajeev,
Brett here. Got a weird one, or maybe it is not that weird since it involves a Chrysler product and electrical gremlins. My father drives a 2006 Jeep Commander, 5.7-liter HEMI, basically loaded. Overall, he likes the Jeep. It has about 104k miles on it. Anyways, it is his forth Jeep and he is having some weird electrical problems.

Imagine that, a Chrysler product with electrical problems… (Read More…)

By on March 14, 2012

 

Chris writes:

Hey Sajeev,

Long time lurker here.  Since you asked so nice, here’s a problem that I haven’t managed to troubleshoot myself, and so far my own searches & forum postings haven’t nailed an answer. My girlfriend drives a 99 Mazda Protégé.  If driven for an extremely short distance (like from the street into the garage), it will not start the next morning.  It turns over just fine, but doesn’t catch. (Read More…)

Recent Comments

  • rossasaurus: Just noting that in the Corbin Sparrow, you are sitting on top of the main portion of the Battery, which...
  • Dave M.: Interesting reflection. I’ve loved Accord’s styling direction these past 2 generations, but...
  • JohnTaurus: Not really a fan of the car’s body itself, but, the polished aluminum finish looks amazing. Imagine...
  • carguy67: Profile looks a lot like an E-Type. Wonder how it would fare against current Ferraris?
  • scott25: And yes I meant Lynk & Co.

New Car Research

Get a Free Dealer Quote

Staff