Tag: no start

By on August 18, 2015

 

2010_jeep_commander-pic-6910025025120850825

(photo courtesy: productioncars.com)

Brett writes:

Sajeev,
Brett here. Got a weird one, or maybe it is not that weird since it involves a Chrysler product and electrical gremlins. My father drives a 2006 Jeep Commander, 5.7-liter HEMI, basically loaded. Overall, he likes the Jeep. It has about 104k miles on it. Anyways, it is his forth Jeep and he is having some weird electrical problems.

Imagine that, a Chrysler product with electrical problems… (Read More…)

By on March 14, 2012

 

Chris writes:

Hey Sajeev,

Long time lurker here.  Since you asked so nice, here’s a problem that I haven’t managed to troubleshoot myself, and so far my own searches & forum postings haven’t nailed an answer. My girlfriend drives a 99 Mazda Protégé.  If driven for an extremely short distance (like from the street into the garage), it will not start the next morning.  It turns over just fine, but doesn’t catch. (Read More…)

Recent Comments

  • tonyola: The gang from the Peanuts comic strip were used as shills to push Ford Falcons. https://www.youtube.com/wa...
  • Lorenzo: The company making them was in Los Angeles, and probably most of them never left Southern California.
  • Lorenzo: I think that was the 200 cid, the base six for the Fairlane in the 1960s, and the original engine for the...
  • IBx1: There’s a convertible one from my town I see most days as of a month ago on my commute to work and back. The...
  • Fred: I see those Skoda wagons on European bike races and wish we could get something like that. Then again I...

New Car Research

Get a Free Dealer Quote

Staff

  • Contributors

  • Matthew Guy, Canada
  • Ronnie Schreiber, United States
  • Bozi Tatarevic, United States
  • Chris Tonn, United States
  • Corey Lewis, United States
  • Mark Baruth, United States
  • Moderators

  • Adam Tonge, United States
  • Corey Lewis, United States