By on September 3, 2014

 

TTAC Commentator Eiriksmal writes:

I read your plea for questions, so I’ll lob you a softball. Why has my 2005 Maxima’s TPS decided to randomly poop out on me after doing a warm start?

Specs: 2005 Nissan Maxima 6MT. 135,000 miles. Electronic throttle. Stock air intake + (new, put in the first time the TPS acted up 3K miles ago) K&N filter. The car’s now on its third owner, having spent its whole life in Evansville, IN, Lexington, KY, and now Louisville, KY. At the rust belt’s frayed fringe, I guess. No surface rust anywhere on the car, though. Electrically speaking, it’s in good shape. (Save the rear ABS sensors… a rant for another day)

(Read More…)

By on January 10, 2012

Steven writes:

Sajeev and Steve,

Ok guys need some advice, I am the owner of an 2001 Volvo XC wagon with 166,000 on it, I have owned it about 2 years and drive about 40k a year all over the North East for work. It is paid off but in the last 6 months I have put about 4 K in it, new tires, new brakes all around water pump, T belt, new moon roof (do not ask), the previous owner replaced the tranny at 110k and put a new cat convertor at 100k. (Read More…)

Recent Comments

  • backtees: Can’t wait for these to be 2 years out and be a heck of a buy. Had a 2000 lasabre that was the...
  • Dave M.: My brother in law just got $6500 off msrp on a loaded ’17 Avalon. Buick can’t touch that on a...
  • karonetwentyc: Two years to delivery was positively fast for Morgan at that time, but I can absolutely believe it. We...
  • sgeffe: Hmm..wonder if Honda’s already planning some sort of emergency cleanup, 2013 Civic-style, on the...
  • karonetwentyc: Perhaps McLaren could make the trip from Woking to Malvern Link and discuss their theories regarding...

New Car Research

Get a Free Dealer Quote

Staff