Tag: egr

By on April 11, 2014

1.3L_gasoline_engine

Toyota has unveiled this week two new fuel-efficient gasoline engines that will serve as the basis for as many as 14 global powerplants by 2015, and boost economy by 10 percent.

(Read More…)

By on April 10, 2014

EGR Buick Regal Gets 40 MPG

The current Buick Regal is an excellent car. I know, because I have one parked in my garage (it’s sweet). Still, it could be better- and the guys at the SouthWest Research Institute (SWRI) have figured out a way to enhance the mid-range Buick so that it produces fewer harmful carbon emissions and gets better fuel economy.

Can’t beat that!

(Read More…)

By on March 5, 2014

TTAC Commentator sundvl76 writes:

Sajeev,

Your post of 2 Mar 2011 was a great explanation regarding the cause of the “T” joint oil leak I’ve been experiencing. No one on any of the normal Ford sites has been able to pinpoint the problem, so I thank you for the information. (I’d discovered the source, but didn’t know the cause/fix until your post.) TTAC is now on my Favorites list! (Read More…)

By on July 5, 2013

Tony_Montana_Coke

Brian writes:

Hi Sajeev,

I have a 1999 Nissan Frontier. 207k miles, 2.4L four cylinder. I have a Service Engine light which comes on AFTER driving for 30 minutes, parking it and letting it sit for 30 minutes. When I come back and start the truck I get the vibration and Service Engine light. The code is a P0303, i.e. cylinder #3 misfire. (Read More…)

By on June 4, 2012
Nate writes:

Hi Sajeev,

You asked for some emails, so here’s one from me. It may not be Piston Slap worthy, but it’s got me confused. Here’s my problem:

I have a 1998 Nissan Frontier. 150k miles, 2.4l four banger. It threw a Service Engine light on me the other day. The code is a P0301, i.e. cylinder #1 misfire. Figuring it was a spark plug issue, and since I was about due for a tune up anyway, I replace the plugs, wires, distributor cap and rotor. I cleared the code with my scanner, and….it came right back. I did a little creeping on the Nissan forums, and the consensus seems to be that this results from clogged EGR passages. So this past weekend I decided to clean them. I was lead to believe that this would be a cake walk. All that was required was to remove the set screws between the intake runners, spray some carb cleaner in there and scrub them out. Easier said than done. Removing the screws was not too bad, but putting them back in after cleaning was nigh impossible. 5 hours and sawed off 8mm Allen wrench later, I had the plugs back in. My truck ran great! For 20 minutes. Then the code came back. Now I’m pretty much flummoxed. The way I see it, my options are:

1. Remove the air cleaner assembly and manifold screws again and try cleaning them more thoroughly with a pipe brush and more carb cleaner
2. Try something like Seafoam through a vacuum hose. I am reluctant to do this as I’m not 100% sure which hose to use and opinions on Seafoam are mixed
3. Take my vehicle to a mechanic for a more professional diagnosis. I do have access to a reputable independent mechanic who specializes in Nissans and Toyotas

So, what do the B&B think? Anyone else had this problem with a Nissan KA24DE 4 cylinder?

Thanks for your help. (Read More…)

Recent Comments

New Car Research

Get a Free Dealer Quote

Staff

  • Authors

  • Brendan McAleer, Canada
  • Marcelo De Vasconcellos, Brazil
  • Matthias Gasnier, Australia
  • W. Christian 'Mental' Ward, Abu Dhabi
  • Mark Stevenson, Canada
  • Faisal Ali Khan, India